RPGMod_Fire Elementals Pack and RPGMod_Ice Elementals Pack Help me?

First of all, I'm new here, sorry if I'm posting in the wrong place. I want to use the "_RPGMod_Fire Elementals Pack" ve "_RPGMod_Ice Elementals Pack" package, but I keep getting an error.
Combat Dependencies are attached in the hierarchy, but I get error messages when the enemy attacks me or when I attack her. How can I solve this problem, can you please help?
Thanks in advance for the answers.

Probably need to update all of the NPC scripts from the latest version of NPC AI Kit and make sure you've downloaded the most recent version of combat dependencies.

1 Like

First of all thank you for the reply.
I opened a new project after your message.
I added "NPC AI Kit" and "_RPGMod_Ice Elementals Pack" from the Community Content window.
I added the Combat Dependencies that come in the NPC AI Kit package to the hierarchy.
I added an NPC that came in the _RPGMod_Ice Elementals Pack to the hierarchy.
I got different error messages when NPC attacked me and different when I attacked.
I don't fully understand, but do the NPCs that come with the Packages need to be saved in another file?
Example error messages are in the picture.

Well, I loaded it into my game and messed with it. I dropped the lowest level one into one of my projects and updated all of the scripts in it's template with the ones from the current NPC AI Kit. You can do this by manually dragging each script from the kit into the corresponding script reference in the template. You do this for every script referenced in the AI Server, Attack Server, AI Client, and Attack Client in the NPC's template.

Fired up my game, NPC triggered no errors. Hooray.

NPC immediately killed itself with it's own attacks upon aggro. Sadface.

I'm going to go mess with it some more.


UPDATE: It is now killing me instead of itself. It is also now invisible. I shall continue.

Assigning it a team number either directly or through a spawner resolved the suicidal tendencies.


UPDATE 2: Resolved the invisibility issue. The NPC was using a deprecated NPC skeleton "Human Fantasy Guy" as it's base. I replaced it with the Humanoid 2 animated mesh, in this case Karl. I turned off visibility for the animated mesh and replaced all of the asset references for Human Fantasy Guy with the new mesh in both the AI Client and the attach_costume_script.

Hooray for deprecated assets!

1 Like

TLDR- This template has a ton of outdated scripts and assets and I needed to go through and replace them all to get it to work.

1 Like

I messed around a bit and solved it thanks to your explanation. Yes, the NPC was invisible and killing itself when I tried it too. As you said, I replaced the script files of the NPCAIServer and NPCAttacServer files in the properties window with the files that came with the NPC AI Kit ve and I didn't get an error. However, when I changed the NPCAIClient file, it gave an error.

1- I set NPC's Team value to 2
2- I replaced the scripts in the properties window of the NPCAIServer file, which appears under NPC in the hierarchy, with the ones that came with the NPC AI Kit.
3- I replaced the scripts in the properties window of the NPCAttacServer file, which appears below the NPC in the hierarchy, with the ones that came with the NPC AI Kit.

In this way, I tested all the NPCs that came with the Ice Elemental Pack without any errors, and they all worked without any problems. I solved the problem thanks to your help.

Thank you LordPazuzu.

1 Like