Basic Problem with Spawning a template based on Cube


This is the problem: I've made a template from basic Cube object . It is a modified Cube, with new material and changed scale (it's like a thin segment of metal(. It is visible in the list of templates and has its own name.

Now I drag it into the Script properties. And when the script spawns it, it shows as a standard cube without changed scale (although material is there!).

I have tried to instance that template in the world, click and drag that modified cube from hiearchy to script property, but when I try to spawn that from script, I get an error message on SpawnAsset (gets StaticMesh instead of string).
Where am I making a mistake?

Thanks in advance

Are you putting the cube in a template, then sizing the template? Size the cube within the template. The template will be spawned at size 1,1,1. The dimensions of objects set individually within the template should be saved and appear accordingly.

I have solved it by putting a cube into the folder and than making a template of that folder. Then it showed up in proper dimensions, as I have modeled it.

You're welcome from discord :wink:

Thank you for the solution you gave on Discord !